#1  
Old October 23rd, 2009, 02:03 AM
Hazomg Hazomg is offline
Junior Member
NETGEAR Newbie
 
Join Date: Oct 2009
Posts: 3
Hazomg is on a distinguished road
Default WN121T - Windows 7 X64 compatibility

I have tried to install my WN121T in Windows 7 x64 and it simply isn't working. This has resorted me to go back to xp until there are some drivers that work. I have used the latest drivers from the net gear website to no avail.

How long do I expect to be waiting for some X64 Windows 7 compatible drivers to be released and what can I do at the moment to get this wireless card working?

Thanks for the help in advance

Harry
Reply With Quote
  #2  
Old October 23rd, 2009, 07:40 AM
choc choc is offline
Junior Member
NETGEAR Newbie
 
Join Date: Feb 2009
Posts: 7
choc is on a distinguished road
Default Re: WN121T - Windows 7 X64 compatibility

By reading this thread you can get some drivers: http://forum1.netgear.com/showthread...ight=win7+121t

They offer basic functionality and are not the most stable, but they work. As for official support and a new driver... your guess is as good as anyone else. Its becoming clear that Netgear lack the ability to A) Keep customers informed on progress or B) Produce timely updates for products.

How long have they had to prepare for Win7 and sill only 4 adapters get drivers. Worst manufacturer of any product in my systems.
Reply With Quote
  #3  
Old October 23rd, 2009, 08:43 AM
Hazomg Hazomg is offline
Junior Member
NETGEAR Newbie
 
Join Date: Oct 2009
Posts: 3
Hazomg is on a distinguished road
Default Re: WN121T - Windows 7 X64 compatibility

Thanks for that.

It would be nice if Netgear get their asses in line and release some drivers for a nearly new product that they sell, they have had long enough ...
Reply With Quote
  #4  
Old October 29th, 2009, 10:13 AM
BlitzXor BlitzXor is offline
Junior Member
 
Join Date: Oct 2009
Posts: 1
BlitzXor is on a distinguished road
Default Re: WN121T - Windows 7 X64 compatibility

I am using the 5.2 x64 drivers on Windows 7 and they seem to be working fine so far (knock on wood).

I followed the install as per usual, and when it told me to connect the adapter I did and the adapter was not recognized. However, without cancelling the install, I went into the device manager and right-clicked on the non-functioning network adapter and asked Windows to troubleshoot, it asked me to install a driver, and I told it to automatically detect the driver. At this point the 5.2 installer recognized the adapter and proceeded with installation, and as I said, it appears to be working just fine, however I do have to reset the adapter every couple of days because the driver hangs.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 11:03 PM.