#1  
Old October 20th, 2011, 08:41 PM
sngbrdb sngbrdb is offline
Junior Member
NETGEAR Newbie
 
Join Date: Oct 2011
Posts: 5
sngbrdb is on a distinguished road
Exclamation WNDR3800 doesn't ask for password at login??!?

Just got my 3800 set up and running. I changed the default SID, etc., and password to the router administration. But when I log out, then return to the main page, I'm logged in, and can still see everything (including my wireless password and logs)!!!!

After setting it and logging out a number of times, I convinced myself it's really and truly not checking the password for login as follows:
  1. Logged out of the router in firefox and closed the page
  2. Logged into the router in IE
  3. Changed the password in IE
  4. Logged out in IE
  5. Opened up the router homepage in firefox. I'm magically in, I did not need to enter the new password.

I'm running the newest firmware, 1.0.0.24... is this a problem with this version of the firmware? Need this fixed ASAP!!
Reply With Quote
  #2  
Old October 20th, 2011, 10:14 PM
Mars Mug's Avatar
Mars Mug Mars Mug is offline
Moderator
NETGEAR Fanatic
 
Join Date: Nov 2006
Location: Stevenage UK
Posts: 12,548
Mars Mug is on a distinguished road
Default Re: WNDR3800 doesn't ask for password at login??!?

The login details are retained for the current browser session and will be lost if the browser itself is closed or the PC shutdown, this is common for many networking devices not just Netgear devices. Higher end equipment intended for a multi-admin environment such as an office may use https: but for home use the session login is unlikely to be an issue since only one user can login at a time.
__________________
I don't work for Netgear.

My name is Andy.
Reply With Quote
  #3  
Old October 21st, 2011, 06:08 AM
zipperx zipperx is offline
Junior Member
NETGEAR Newbie
 
Join Date: Sep 2011
Posts: 17
zipperx is on a distinguished road
Default Re: WNDR3800 doesn't ask for password at login??!?

I also just updated to the latest firmware (1.0.0.24) and it won't logout. Tried a browser restart, flush cache, reboot. No joy. It is broken

Also broken is the UPnP. There is no more Internet Gateway in my network connections
Reply With Quote
  #4  
Old October 21st, 2011, 06:24 AM
zipperx zipperx is offline
Junior Member
NETGEAR Newbie
 
Join Date: Sep 2011
Posts: 17
zipperx is on a distinguished road
Default Re: WNDR3800 doesn't ask for password at login??!?

Quote:
Originally Posted by zipperx View Post
Also broken is the UPnP. There is no more Internet Gateway in my network connections
Ahhh the gateway came back. Some kind of delay
Reply With Quote
  #5  
Old October 23rd, 2011, 10:15 AM
sngbrdb sngbrdb is offline
Junior Member
NETGEAR Newbie
 
Join Date: Oct 2011
Posts: 5
sngbrdb is on a distinguished road
Default Re: WNDR3800 doesn't ask for password at login??!?

Quote:
Originally Posted by Mars Mug View Post
The login details are retained for the current browser session and will be lost if the browser itself is closed or the PC shutdown, this is common for many networking devices not just Netgear devices. Higher end equipment intended for a multi-admin environment such as an office may use https: but for home use the session login is unlikely to be an issue since only one user can login at a time.
But what I'm saying is, if I log out in Firefox, and use Internet Explorer to change the password, Firefox is still not prompted for the password when I return to the administration page. Once the password is changed, the cached login details should be invalid. Once I log out, the cached login should be invalid. Once the browser is closed, the cached login should be invalid.

I just hit the admin page again; haven't visited it in two days. I can see everything, not prompted for a password. If some kind of token is persisting that the router accepts because I logged in once who-knows-how-long-ago, then Netgear has a fix to release. Because that is NOT any kind of standard security practice, and it's not acceptable.

It concerns me that a company who makes routers has a problem with standard security practices... It casts doubt as to what else they are screwing up.
Reply With Quote
  #6  
Old October 23rd, 2011, 11:32 PM
Mars Mug's Avatar
Mars Mug Mars Mug is offline
Moderator
NETGEAR Fanatic
 
Join Date: Nov 2006
Location: Stevenage UK
Posts: 12,548
Mars Mug is on a distinguished road
Default Re: WNDR3800 doesn't ask for password at login??!?

If what zipperx said in Post #3 is correct, and I have no reason to disbelieve what was said, then your router is operating differently to all other Netgear home grade routers I have used (that’s a lot) and I would say that the symptoms you describe are a fault, it should not be doing what you and zipperx describe.
__________________
I don't work for Netgear.

My name is Andy.
Reply With Quote
  #7  
Old October 24th, 2011, 10:02 AM
Joe_ Joe_ is offline
Senior Member
NETGEAR Addict
 
Join Date: May 2011
Posts: 2,278
Joe_ is on a distinguished road
Default Re: WNDR3800 doesn't ask for password at login??!?

Check to see if you have your browser(s) configured to save your password(s).

In IE9:

- Click on (the gear icon in top right corner) Tools>Delete Browsing History...

- Scroll down to Passwords and ensure that box is unchecked.

I haven't been using FF, but you should find a similar option if you look around.
Reply With Quote
  #8  
Old October 24th, 2011, 10:17 AM
Joe_ Joe_ is offline
Senior Member
NETGEAR Addict
 
Join Date: May 2011
Posts: 2,278
Joe_ is on a distinguished road
Default Re: WNDR3800 doesn't ask for password at login??!?

Sorry, that should be "make sure the box is checked". Next, delete your browsing history.

You could also configure IE9 to Empty Temporary Internet Files Folder When Browser is Closed. You'll find that option under Tools>Internet Options>Advanced.

Alternatively, you could use In Private browsing mode which will automatically delete your browsing session upon exit. Go to Tools>Safety>InPrivate Browsing.

(Other thoughts: Wish I had the option to edit my posts. )
Reply With Quote
  #9  
Old October 24th, 2011, 09:11 PM
Jegan Jegan is offline
Junior Member
 
Join Date: Oct 2011
Posts: 3
Jegan is on a distinguished road
Default Re: WNDR3800 doesn't ask for password at login??!?

Hello,

My device is weeks new. I'm having the exact same issues.

I can confirm that this has nothing to do with browsers saving passwords. This same issue occurs on a brand new fresh install PC.

All in all, the *18 firmware step-up to *24 has been an absolute disaster in terms of security vulnerabilities. No connection, outside or in requires authentication on the router. This is scary!

Above that, 'Block Services' and 'uPnP' doesn't do what it's told and many of my ports are being left open.

I have never heard or experienced such issues with Netgear devices in the past, ever!

I would check with the developers on who had a hand in programming the latest firmware. To me, it seems a bit suspicious.

PLEASE GIVE FULL ATTENTION TO THIS ISSUE

Looking forward to a resolution ASAP.

Thank you.
Reply With Quote
  #10  
Old October 24th, 2011, 11:04 PM
Jegan Jegan is offline
Junior Member
 
Join Date: Oct 2011
Posts: 3
Jegan is on a distinguished road
Default Re: WNDR3800 doesn't ask for password at login??!?

In the meantime, I suggest everyone to revert back to firmware 1.0.0.18
( http://support.netgear.com/app/answe...rsion-1.0.0.18 )

Unless the updates found here for 1.0.0.24 is more essential to you
http://forum1.netgear.com/showthread.php?t=70839
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 06:11 PM.