#1  
Old May 6th, 2012, 02:06 PM
edoc edoc is offline
Junior Member
NETGEAR Newbie
 
Join Date: May 2010
Posts: 35
edoc is on a distinguished road
Default Android IP Webcab & Router?

I have loaded the following app to my Android phone:

[URL="https://play.google.com/store/apps/details?id=com.pas.webcam&feature=search_result#?t =W251bGwsMSwxLDEsImNvbS5wYXMud2ViY2FtIl0."[/URL]

The process is that it's supposed to connect wirelessly through the router to my laptop.

I am getting an IP that starts with a 10 and not a 192, so it's not seeing the router.

I turned-off NAT in Port Forwarding but it still does not connect.

Is this more likely a problem at the Android end, the router, or both?

Thanks!
Reply With Quote
  #2  
Old May 6th, 2012, 04:22 PM
jmizoguchi's Avatar
jmizoguchi jmizoguchi is offline
Junior Member
 
Join Date: Feb 2007
Location: Kentucky, USA
Posts: 0
jmizoguchi is an unknown quantity at this point
Default Re: Android IP Webcab & Router?

if you have 10. IP then you have not setup broadband and router correctly

see rouer setup on my sig below
Reply With Quote
  #3  
Old May 7th, 2012, 05:35 AM
fordem fordem is offline
Senior Member
NETGEAR Fanatic
 
Join Date: Nov 2006
Posts: 7,356
fordem is on a distinguished road
Default Re: Android IP Webcab & Router?

Ahhhh - what makes you think that your router is involved in this?

You have a "webcam" app that turns your phone into a webcam, accessible by any device - my assumption would be that you're going to try to connect to the webcam via the mobile providers network (I hope you have an unlimited data plan).

I suspect the 10.x.x.x ip you are seeing is from your mobile service provider - at least - it's typical of what I would see when I mucked around with mobile data plans a while back.

You'll probablyt be better off discussing the problem with the app vendor.
__________________
Give a man a fish, feed him for a day
Teach a man to fish, feed him for life.
Reply With Quote
  #4  
Old May 7th, 2012, 06:05 AM
edoc edoc is offline
Junior Member
NETGEAR Newbie
 
Join Date: May 2010
Posts: 35
edoc is on a distinguished road
Default Re: Android IP Webcab & Router?

Quote:
Originally Posted by jmizoguchi View Post
if you have 10. IP then you have not setup broadband and router correctly
see router setup on my sig below
I have 192 for everything (multiple laptops and a couple of handheld devices, e.g. ipods) except the cellphone.

Do I still need to locate and toggle "bridge mode"?

That setting would be under Basic - Wireless - Wireless Mode, in Tomato, and would be labeled "Wireless Internet Bridge"?

Also, in Port Forwarding, do I want any of these three toggled on?

Enable UPnP
Enable NAT-PMP
Secure Mode

Thanks!
Reply With Quote
  #5  
Old May 7th, 2012, 06:18 AM
edoc edoc is offline
Junior Member
NETGEAR Newbie
 
Join Date: May 2010
Posts: 35
edoc is on a distinguished road
Default Re: Android IP Webcab & Router?

Quote:
Originally Posted by fordem View Post
Ahhhh - what makes you think that your router is involved in this?

You have a "webcam" app that turns your phone into a webcam, accessible by any device - my assumption would be that you're going to try to connect to the webcam via the mobile providers network (I hope you have an unlimited data plan).

I suspect the 10.x.x.x ip you are seeing is from your mobile service provider - at least - it's typical of what I would see when I mucked around with mobile data plans a while back.

You'll probablyt be better off discussing the problem with the app vendor.
I have been in touch with the app vendor.

He wrote this - perhaps you can help me to understand what he means?

Quote:
My app is accessible via any network you're connected to. However, I strongly suggest to start with WiFi, because it's a network you can control.
So, here's the procedure. Your phone connects to a network. It can be WiFi, Ethernet, Mobile network or any other. When doing so, your phone acquires an address, allocated to it by a special service inside a network (in WiFi case your router does that). Then my app comes into play. When you start the streaming, my app opens a port on all addresses your phone has (usually it's only one, since Android tries to close unused connections).

Now, any computer that can "see" your address can connect to this service and remotely view the video.

Also, check that the address (it's 192.168.3.198 part of http://192.168.3.198:8080 URL) starts with 192.168. It's a private subnet (invisible from the outside) which is allocated by default by routers. If it starts with 10 or something else, chances are you're not connected to WiFi.
His most recent E-mail said this:

Quote:
It's "Client isolation" you should disable, if you have this option. As the name suggests, it prevents NAT clients from "talking" to each other.
Reply With Quote
  #6  
Old May 7th, 2012, 09:01 AM
jmizoguchi's Avatar
jmizoguchi jmizoguchi is offline
Junior Member
 
Join Date: Feb 2007
Location: Kentucky, USA
Posts: 0
jmizoguchi is an unknown quantity at this point
Default Re: Android IP Webcab & Router?

Quote:
Originally Posted by edoc View Post
I have 192 for everything (multiple laptops and a couple of handheld devices, e.g. ipods) except the cellphone.

Do I still need to locate and toggle "bridge mode"?

That setting would be under Basic - Wireless - Wireless Mode, in Tomato, and would be labeled "Wireless Internet Bridge"?

Also, in Port Forwarding, do I want any of these three toggled on?

Enable UPnP
Enable NAT-PMP
Secure Mode

Thanks!
Your cell phone must not hooked up to your own wireless network
Reply With Quote
  #7  
Old May 7th, 2012, 09:20 AM
Scubbie's Avatar
Scubbie Scubbie is offline
Senior Member
NETGEAR Addict
 
Join Date: Jun 2011
Location: Hampshire, England
Posts: 1,110
Scubbie is on a distinguished road
Default Re: Android IP Webcab & Router?

Basically, rather than give each phone its own IP address that can be accessed by other devices on the Internet, you have a LAN IP Address.

If you happen to have another phone on the same network and same tower, type in the IP Address, with the port number, into its browser and you should be able to connect to the IP Webcam output.

If you were to search google for a site to show the actual Internet IP Address, you should find that you have at different number. Since you can access the system to forward the specific port to your phone, it won't work whilst you are connected outside your home network.
Reply With Quote
  #8  
Old May 7th, 2012, 12:55 PM
fordem fordem is offline
Senior Member
NETGEAR Fanatic
 
Join Date: Nov 2006
Posts: 7,356
fordem is on a distinguished road
Default Re: Android IP Webcab & Router?

You need to start by getting connecting your phone connected to your WiFi network - go into Settings, open Wireless and networks, and then Wi-fi settings, and Add your network - once you have done that, you should be able to see the ip address (and this time it should have a 192.168 address) and you should be able to connect to it (after starting the app).
__________________
Give a man a fish, feed him for a day
Teach a man to fish, feed him for life.
Reply With Quote
  #9  
Old May 7th, 2012, 03:24 PM
edoc edoc is offline
Junior Member
NETGEAR Newbie
 
Join Date: May 2010
Posts: 35
edoc is on a distinguished road
Default Re: Android IP Webcab & Router?

Problem solved.

I replaced the router with a new N600/WNDR3400v2 from Walmart.

The "Bridge Mode" recommendation bricked the other router and I could not get it to reset.

The N600 handled the IP Webcam fine without any need for adjustments.

Thanks!
Reply With Quote
  #10  
Old May 7th, 2012, 04:06 PM
jmizoguchi's Avatar
jmizoguchi jmizoguchi is offline
Junior Member
 
Join Date: Feb 2007
Location: Kentucky, USA
Posts: 0
jmizoguchi is an unknown quantity at this point
Default Re: Android IP Webcab & Router?

bridge mode does not brick 100% , impossible...

just defective router
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 05:31 AM.